www.zkurd.org
ئه‌ندامه‌تی پرۆژه‌كان مه‌کۆ تاقیكاری IT فه‌رهه‌نگی ماڵه‌وه
  zanistperweran



پۆستی ئه‌له‌كترۆنی
(ته‌نها بۆ ئه‌ندامانه‌)
ناو
تێپه‌ڕه‌وشه‌
له‌ لایه‌ن safen ه‌وه‌، ‌ ڕێكه‌وتی ٢٠٠٦/١١/١٩    

نه‌خشه‌ و فۆرمۆلا له‌ ئێكسێڵدا (Formulas & Functions in Excel)


ناوه‌ڕۆكی ئه‌م وتاره‌
پێشه‌كی
فۆرمۆلا و نه‌خشه‌ چییه‌؟
جیاوازیی نێوانیان چییه‌؟
چه‌ند نه‌خشه‌ی ئاما‌ده‌كراو له‌ ئێكسڵدا هه‌یه و له‌ كوێدان‌؟
ڕاهێنان:-
داگرتن






پێشه‌كی
له دوو بابه‌تی ڕابردوودا فێر بووین ئێكسڵ چییه و چۆن (خشته Table) یه‌ك درووست بكه‌ین، تا ئه‌وێ ئێكسڵ له خشته‌یه‌كی ڕه‌نگاوڕه‌نگ هیچی دی نییه.

بۆ ئه‌وه‌ی زانیاریی ژمێریاری و ئاماری تایبه‌تی‌ یان هه‌ر كارێكی بیركاریمان ده‌ست كه‌وێت ئه‌وا پێویستیمان به (فۆرمۆلا Formula) و (نه‌خشه Function) هه‌یه، كه ده‌توانین به كرۆكیی پرۆگرامی ئیكسڵیان دانێین.

فۆرمۆلا و نه‌خشه‌ چییه‌؟
كۆمه‌ڵێك هێمای زانستی و بیركارییه‌ كه‌ به‌ هۆیانه‌وه‌ ده‌توانین فه‌رمان بده‌ینه‌ ئێكسڵ بۆ وه‌دیهێنانی ده‌ره‌نجام به شێوه‌ی‌ (خۆكار Automatic) ی یان ڕێكخستنی زانیارییه‌كان.

تێبینی
هه‌موو فۆرمۆلا و [نه‌خشه‌Function]یه‌ك مه‌رجه‌ به‌ هێمای (=) یه‌كسان ده‌ست پێ بكات تا ئێكسڵ به‌ فۆرمۆلا یان فه‌نكشن بیناسێت.

جیاوازیی نێوانیان چییه‌؟
- [نه‌خشه‌Function] كۆمه‌ڵێك ( فۆرمۆلای ئاماده‌كراوه Prewritten formulas) ‌ له‌ ناو ئێكسێڵدا كه‌ زۆر یارمه‌تیده‌ره‌ بۆ كه‌مكردنه‌وه‌ی كات وه‌ كورتكردنه‌وه‌ی هێماكان
- نه‌خشه‌و فۆرمۆلا به‌ یه‌كه‌وه‌ ده‌بنه‌ فۆرمۆلا!.
- فۆرمۆلای ساده‌ (بێ نه‌خشه‌) ده‌توانرێ به‌كار بێت به‌ڵام سنوورداره‌ له‌ تواناكانیدا.

نموونه‌:- ‌
- فۆرمۆلا بێ نه‌خشه‌


www.zkurd.org


ئه‌گه‌ر سه‌یری ئه‌و خشته‌ی سه‌ره‌وه‌ بكه‌ین له‌ خانه‌ی E1 دا كۆی ساده‌مان به‌كار هێناوه‌ داوای ده‌ره‌نجامی كۆی خانه‌كانی A1,B1,C1,D1 مان كردووه، كه‌ ده‌كاته‌ ژماره‌ (١٤). به‌ڵام بیر كه‌ره‌وه‌ ئه‌گه‌ر كۆی ١٠٠ خانه‌مان بویستایه‌ ئه‌وا ده‌بوا هه‌موو ئه‌و خانانه‌ بنووسین كه ئه‌مه‌ كاتی زۆری ده‌وێ وه‌ باری ئێكسڵیش قورس ده‌كات!

- فۆرمۆلا و نه‌خشه‌ پێكه‌وه‌
ئا لێره‌دا گرنگیی نه‌خشه‌ ده‌رده‌كه‌وێ به‌ یه‌ك فه‌رمانی بچووك ئه‌و كاره‌ ئاسانتروو خێراتریش ده‌كه‌ین سه‌رنج بده‌ هه‌مان نموونه‌ به‌ڵام به‌ به‌كار هێنانی (نه‌خشه‌ Function)


www.zkurd.org


(=) وه‌ك باسمان كرد ده‌ستپێكردنی هه‌موو نه‌خشه‌ و فۆرمۆلایه‌ك به‌م هێمایه‌یه.
SUM نه‌خشه‌ی ئاماده‌یه ‌له‌ ئێكسڵدا به‌ مانای كۆ دێت.
(:) ئه‌م هێمای دوو خاڵه‌ له‌ ئیكسڵدا ئاماژه‌ پێكردنی ئه‌و خانانه‌یه‌ كه‌ ده‌مانه‌وێ ده‌ره‌نجامه‌كانمان بداتێ واته (له‌ :تاوه‌كو‌).
(A1:D1) لێره‌ش به‌ ئێكسڵمان فه‌رمان داوه‌ كه‌ كۆی خانه‌ی (A1) تا (D1) مان داتێ، دیاره‌ ئه‌و خانانه‌ش كه‌ كه‌وتوونه‌ نێوانیان.
كه‌واته‌ یه‌كێك له‌ ساكارترین فۆرمۆلای ئێكسڵمان درووست كرد كه‌ به‌م شێوه‌یه‌یه‌:


www.zkurd.org


چه‌ند نه‌خشه‌ی ئاما‌ده‌كراو له‌ ئێكسڵدا هه‌یه وه‌ له‌ كوێدان‌؟
بۆ بینینی نه‌خشه‌كان كلیكی Insert ده‌كه‌ین و پاشان Function هه‌لده‌بژێرین.


www.zkurd.org


ئه‌م په‌نجه‌ره‌یه‌مان بۆ ده‌كرێته‌وه‌ كه‌ نه‌خشه‌كانی تێدا كراونه‌ته‌ چه‌ند (هاوپۆل Category) ێك.


www.zkurd.org


ده‌توانین بڵێین نزیكی (٣٤٤ وه‌ زیاتر) نه‌خشه‌ن به‌پێی وه‌شان و زمان ده‌گۆڕین، وه‌ك باسمان كرد دابه‌ش كراونه‌ته‌ سه‌ر چه‌ند (هاوپۆلیك Category)

دارایی Financial
ڕیكه‌وت و كات Date & Time
بیركاری و بیردۆزی Math & Trig
ئاماری Statistical
گه‌ڕان و ئاماژه‌ Lookup & Reference
بنكه‌دراوه‌ Database
ده‌ق Text
ژیربێژی Logical
زانیاری Information
ئه‌ندازیاری Engineering

وه‌ك له‌ بابه‌ته‌كانی پێشوو باسمان كرد زانیاریی خانه‌‌كان Formula bar كه‌ به‌شێكی گرنگی ئێكسیڵه‌ هه‌‌ر خانه‌یه‌ك چالاك بكه‌ین له‌و سندووقه‌دا پیشانمان ده‌دات ئه‌و خانه‌یه‌ چ كردارێكی تێدا كراوه ، ئه‌گه‌ر ته‌نها نووسین (ده‌ق text) بێت ئه‌وا هه‌‌مان نووسین نیشان ده‌داته‌وه،‌ به‌ڵام ئه‌گه‌ر كاری فۆرمات یان فۆرمۆلات به‌كار هێنرا بێت ئه‌وا به‌ ته‌واوی شتێكی جیاواز ده‌بینی!
واته‌ ئه‌گه‌ر فۆرمۆلامان كردبێته‌ ناو خانه‌یه‌ك ئه‌وا كۆدی فۆرمۆلاكه‌ ده‌بینین له‌ سندووقی زانیاریی خانه‌كان.
بۆ نموونه‌ سه‌یری ئه‌م وێنه‌یه‌ بكه‌:-


www.zkurd.org


سه‌رنج بده‌ ئێمه‌ سێ خانه‌مان پڕ كردۆته:‌
A1 = ژماره‌ ١
B1= ژماره‌ ١
C1= ژماره‌ ٢

ئه‌گه‌ر بێت و خانه‌ی a1 یان b1 مان چالاك بكردایه‌ ئه‌وا هه‌‌مان ژماره‌مان ده‌بینی له‌ زانیاریی خانه‌كان چونكه‌ ته‌نها ژماره‌‌مان نووسیوه‌ و هیچی دی.
به‌ڵام ئێستا له‌ وێنه‌كه‌دا خانه‌ی C1 مان چالاك كردووه‌ كه‌ ژماره‌ دووی تێدا نووسراوه‌ ئه‌ی بۆچی له‌ زانیاری خانه‌كان ژماره‌ دووی نیشان نه‌داوه‌، ئه‌وهێما سه‌یره‌ چییه؟


=SUM(A1:B1)

ئا لێره‌دا فۆرمۆلا ده‌بینی كه‌ مه‌به‌ستم بوو ڕوونی بكه‌مه‌وه‌:-
ئه‌‌گه‌‌ر بۆ هه‌‌‌ر كه‌‌سێك بنووسین ١+١=؟ ئه‌‌وا یه‌‌كسه‌‌ر ده‌زانێ مه‌‌بستمان ئه‌‌وه‌‌یه‌ كۆی یه‌‌ك و یه‌‌ك ده‌‌كاته‌ چه‌‌ند؟
به‌‌ڵام ئێكسیڵ لێمان تێ ناگات ئاوهاا به‌‌ڵكوو زمانی (فۆرمۆلا) تایبه‌‌تیی خۆی هه‌‌‌یه‌.
بۆیه‌ له‌ نموونه‌‌كه‌‌دا به‌‌م شێوه‌‌یه‌ داوامان له‌‌ ئێكسێڵ كردووه‌ ئه‌‌و ژمێریارییه‌‌مان بۆ بكات

= ئه‌‌م هێمایه‌‌ی سه‌‌ره‌تا به‌ ئێكسیڵمان ڕاگه‌‌یاند كه‌ له‌‌م خانه‌‌یه‌‌دا ده‌‌ره‌‌نجامی
شتێكمان پێویسته‌.

SUM لێره‌ پێی ده‌ڵێین پێوستمان به‌ كۆكردنه‌‌وه‌ هه‌‌‌یه‌ بۆیه‌ (Function) ی (SUM) مان
به‌كار هێناوه‌.
(A1:B1) لێره‌ش ناوچه‌‌ی كۆكردنه‌‌وه‌‌كه‌‌مان بۆ دیاری كردووه‌ كه‌
(خانه‌ی یه‌‌كه‌‌م تا(:) خانه‌ی كۆتایی).

تێبینی:

فۆرمۆلا و فه‌‌نكشن ته‌‌واوكه‌‌ری یه‌‌كتریین.
Function به‌ ئاماده‌‌كراوی له‌ ئێكسیڵدا هه‌‌‌یه‌ Insert پاشان Function لێ بده‌ هه‌‌‌موویان ده‌بینی.
Formulas ده‌‌بێ خۆمان دروستی بكه‌‌ین.
هه‌‌‌ندێ جار ده‌توانین فۆرمۆلا بێ فه‌‌نكشن دانێین له‌‌و نموونه‌‌ی سه‌‌ره‌‌وه‌ ده‌‌مانتوانی له‌ خانه‌‌ی C1 له‌ جیاتیی



=SUM(A1:B1) بنووسین =A1+B1 هه‌‌‌مان ده‌ره‌‌نجامی ده‌‌داینێ .

ئه‌‌مه‌ نموونه‌‌یه‌‌كی ساده‌‌ی فۆرمۆلا بوو له‌ ئێكسیڵدا كه‌ به‌ پێویستم زانی درێژه‌ی‌ پێ بده‌‌م چونكه‌ له‌ داهاتوودا زۆری به‌كار دێنین له‌ بابه‌ته‌كانی ئێكسڵدا.


ڕاهێنان:-
پرۆگرامی ئێكسیڵ بكه‌‌ره‌‌وه!‌
١- له‌ خانه‌‌ی A1 ژماره‌ ٢ بنووسه‌!
٢- له‌ خانه‌‌ی B1 ژماره‌ ٢ بنووسه!‌
٣- له‌ خانه‌‌ی C1 ئه‌م فۆرمۆلایه‌ بنووسه‌‌ و Enter لێ بده:‌



=SUM(A1:B1)

٤- ئێستا له‌ خانه‌‌ی C1 ژماره‌ ٤ ده‌‌بینی كه‌ كۆی خانه‌‌ی A1 و B1 خۆكار دانراوه‌!

پرسیار
ئه‌‌و ڕاهێنانه‌‌ی‌ تۆم وه‌‌ك خۆی كرد به‌‌ڵام له‌ خانه‌‌ی C1 ژماره‌ ٤ ی نه‌‌دامێ به‌‌ڵكوو Error ی دامێ بۆچی؟ سه‌یر كه‌!


www.zkurd.org


وه‌‌ڵام
ڕاسته، چونكه‌ ئه‌‌و ئێكسڵه‌‌ی تۆ به‌‌كاری دێنی زمانی ئینگلیزی نییه‌ به‌‌ڵكوو سویدییه‌ بۆیه‌ ئاشنا نییه‌ به‌ فه‌‌نكشنه‌‌كه‌ (SUM).

چاره‌:-
ده‌بێ SUM وه‌‌رگێڕینه‌ سه‌‌ر زمانی سویدی، تكایه‌ فایلی ژماره‌ یه‌ك داگره‌ له‌ كۆتاییی ئه‌م بابه‌ته‌ له‌ خواره‌وه‌ كه‌ په‌رتووكێكی ئێكسڵه‌‌‌ ئه‌‌و وه‌رگێڕانه‌‌ی تێدایه، په‌ڕگه‌كه‌ بكه‌‌ره‌‌وه‌ و بچۆ بۆ ڕیزی ٢٨٣ له‌‌وێ ده‌‌بینی كه‌ به‌ ٧ زمان فه‌‌نكشنی SUM ی داویتێ.

واته‌ فۆرمۆلاكه‌ ئاوا ده‌نوسرێت:



=SUM(A1:B1)

بۆ ئینگلیزی


=SOM(A1:B1)

بۆ هۆڵاندی


=SUMME(A1:B1)

بۆ ئه‌‌ڵمانی


=SOMME(A1:B1)

بۆ فه‌‌ڕه‌‌نسی


=SUMMA(A1:B1)

بۆ سویدی


=SUMMER(A1:B1)

بۆ نۆرویژی


=SUM(A1:B1)

بۆ دانماركی
هتد ...

به‌ڵام ئه‌گه‌ر ئه‌و په‌ڕگه‌یه‌ بنێریت بۆ هاوڕێیه‌كت كه‌ زمانی ئێكسڵه‌كه‌ی جیاواز بێت له‌گه‌ڵ ئه‌وه‌ی خۆت ئه‌وا به‌خته‌وه‌رانه‌ ئێكسێڵ خۆی به‌ شێوه‌ی خۆكاری فه‌نكشنه‌كان وه‌رده‌گێڕێته‌ سه‌ر ئه‌و زمانه‌ واته‌ پێویستت به‌م كاره‌ نییه‌.

ده‌توانین زۆر له‌ سه‌ر فۆرمۆلا بدوێین به‌ڵام ڕه‌نگه‌ لامان ئاڵۆز بێت به‌ باسكردنی بۆیه‌ باشتره‌ كه‌ نموونه‌ی زیندوو پیشان بده‌ین تا خۆت هه‌ندێ ده‌ستكاریی بكه‌یت، تكایه‌ په‌ڕگه‌ی ژماره‌ دوو داگره‌ له‌ خواره‌وه‌ كه‌ په‌رتوكێكی ئێكسڵه‌ چه‌ند نموونه‌یه‌كی گرنگی فۆرمۆلا و فه‌نكشنی تێدایه‌.

داگرتن
تكایه‌ ئاگادار به‌ هه‌ر په‌ڕگه‌یه‌ك داگری پێویستت به‌ به‌رنامه‌ی winzip ده‌بێت بۆ كردنه‌وه‌یان.

١ - په‌ڕگه‌ی ژماره‌ یه‌ك داگره‌

٢ - په‌ڕگه‌ی ژماره‌ دوو داگره‌




chapi bike

پێداچوونه‌وه‌ و ڕاستكردنه‌وه‌ی ڕێنووس، له‌سه‌ر بنه‌مای (ڕێنووسی یه‌كگرتووی زمانی كوردی): دیاكۆ.‌


مافی ئه‌م ماڵپه‌ڕه‌ پارێزراوه‌ بۆ گرووپی زانستپه‌روه‌رانی كورد، بۆ زانیاریی زۆرتر تكایه‌ كرته‌ی ئێره‌ ‌بكه‌
©٢٠٠٣-٢٠١٠